• Welcome to H4O! For a reduced ad experience, please login or register with the forum.

What did you do to your H2 recently?

MilamJR

Well-Known Member
Messages
789
Location
Alabama
Well wtf? I wonder if they made sure both cables were plugged in secure?


Sent from my iPhone using Tapatalk

Has power, has ground and communication wire is good so they think ebcm is bad. He is going to see if he has another one from another vehicle that will at least hook up to see if the scanner can read it.


Sent from my iPhone using Tapatalk
 

Iwillnc

Well-Known Member
Messages
232
Location
NC
As in the entire module? Not just the electronic board?


Sent from my iPhone using Tapatalk
 

MilamJR

Well-Known Member
Messages
789
Location
Alabama
I was out of town all last week but the guy that is working on my H2 was supposed to call the guys who rebuilt my EBCM to see if they have any ideas. He has also been trying to find another EBCM so he can see if the scanner will read it since it will not read mine. If anyone has an extra one please let me know.


Sent from my iPhone using Tapatalk
 

Iwillnc

Well-Known Member
Messages
232
Location
NC
I was out of town all last week but the guy that is working on my H2 was supposed to call the guys who rebuilt my EBCM to see if they have any ideas. He has also been trying to find another EBCM so he can see if the scanner will read it since it will not read mine. If anyone has an extra one please let me know.


Sent from my iPhone using Tapatalk

Just the electronic control board or the entire electronic/ABS valve setup? Basically dry part or full ‘wet’ assembly?


Sent from my iPhone using Tapatalk
 

Iwillnc

Well-Known Member
Messages
232
Location
NC
PM me if you would like.

I have my rebuilt EBCM still wrapped in plastic after being sent off for rebuild. I can ship it to you if you would like - if it works for you you can have it for $50 if not just ship it back.

Only cost to you if you don’t want it would be the shipping back to me if that’s okay with you.
 
Last edited:

Iwillnc

Well-Known Member
Messages
232
Location
NC
27babf319977e54050f42e048bf9e215.jpg


Just so we’re on same page this is the rebuilt part.
 

MilamJR

Well-Known Member
Messages
789
Location
Alabama
PM me if you would like.

I have my rebuilt EBCM still wrapped in plastic after being sent off for rebuild. I can ship it to you if you would like - if it works for you you can have it for $50 if not just ship it back.

Only cost to you if you don’t want it would be the shipping back to me if that’s okay with you.

PM sent. Thanks


Sent from my iPhone using Tapatalk
 

Iwillnc

Well-Known Member
Messages
232
Location
NC
I hope it’s no issue but it will not ship until tomorrow, I was under the assumption the post office stayed open until 5:00 for some reason.
 

Iwillnc

Well-Known Member
Messages
232
Location
NC
We can just do $50 if that’s alright, that will cover shipping and some of my cost of getting it rebuilt.

Otherwise it would have sit here unused so I’m not concerned about making up all the costs.
 

Iwillnc

Well-Known Member
Messages
232
Location
NC
Glad it worked for you! Hopefully you won’t have any further issues.


Sent from my iPhone using Tapatalk
 

witznd

Probationary Member
Messages
3
Location
North Idaho
Hi all...so perhaps it is my blondness but I could figure out how to create a new post...so here we we with my question and I apologize if this is not the right place. I have a 2008 Hummer H2 and my teenage boys recently put in a very awesome Train Horn. However, since then, every once and a while I get a notification that says, SERVICE BATTERY CHARGING SYSTEM and the battery light comes on. I have been doing some research and not sure I have a Battery Current Sensor on this vehicle. But from what I found is if the train horn is grounded to the Neg. battery terminal, which it is, it can cause the battery sensor to do all sorts of crazy things like giving me that error code. When I brought it to Auto Zone they said it was experiencing a parasitic drain but every thing regarding the battery charging system appeared to be fine. Any thoughts? Thank you in advance.
 

MilamJR

Well-Known Member
Messages
789
Location
Alabama
Hi all...so perhaps it is my blondness but I could figure out how to create a new post...so here we we with my question and I apologize if this is not the right place. I have a 2008 Hummer H2 and my teenage boys recently put in a very awesome Train Horn. However, since then, every once and a while I get a notification that says, SERVICE BATTERY CHARGING SYSTEM and the battery light comes on. I have been doing some research and not sure I have a Battery Current Sensor on this vehicle. But from what I found is if the train horn is grounded to the Neg. battery terminal, which it is, it can cause the battery sensor to do all sorts of crazy things like giving me that error code. When I brought it to Auto Zone they said it was experiencing a parasitic drain but every thing regarding the battery charging system appeared to be fine. Any thoughts? Thank you in advance.
I would disconnect the horn and see if that solves the problem. If so you can then work to find a better way to reconnect it.

Sent from my SM-A516V using Tapatalk
 

Unreal

Member
Messages
12
Location
Saudi Arabia
Installed research amp electric side-steps... Amazing product worth every penny... But then I got a fuel pump failure and the H2 got stranded without any source of replacement pump OEM are out of stock everywhere I checked.

Sent from my ONEPLUS A6000 using Tapatalk
 

grod98

Active Member
Messages
25
Location
Ny
In the process of dual fox shocks, all new bushings, ball joints, brakes, axles 64990088230__B5328864-F903-4BA7-BB72-AC9FF5077BAD.jpg
and frame refinish. Bout halfway throughIMG_6897.jpg
IMG_6896.jpg
65016177481__C6CE7108-BEAD-4089-881F-C434EC9BC012.jpg


Sent from my iPhone using Tapatalk
 

Zach

Mall Crawler
Messages
4,812
Location
So Cal
Not a thing. Lol. Tried to jump the pig the other day. The key is now stuck in the ignition cylinder. Although, my Olympic white girl, not birch white lada ta da bs, will be out in Arizona soon. Some special love and been told this one guy, can’t name him, he’s gonna put the lotion on her[emoji15]
 

Zach

Mall Crawler
Messages
4,812
Location
So Cal
I will top all of you. Some have already seen this, and El Diablo, not like you were the last time you called me. Been good lately lol.

So here it goes, redneck engineering. Moving stuff out of the house and back yard. Had to put Luna somewhere. So, I tied her leash to my tie strap to the D ring to the front tow hook of the H2. She if she gets away now
754eea1b3cbdb63f79797e20872572dd.jpg
 
Top